The Infor Communities is globally accessed system by Infor and its customers, please do not post or upload any content that could be deemed as sensitive, confidential or subject to any data regulation requirements. If you are unsure whether or not the content contains sensitive, confidential or has any data regulation requirements, please seek the advice of your internal security, legal, and compliance experts.

Error while running ION API request from H5 SDK

I deployed the sample on H5 and while running the ION request I faced the following issue
GET https://{server}/grid/rest/security/sessions/oauth?rid=WT6IH0WQSDELNQVR 404 (Not Found)

that causes to not authenticating with the ION API.
Can you advice what may be the issue ?

Parents
  • Greetings;

    A 404 error is not a not found reply.  Can you access that URL in a browser?  Is this ST or MT?  That code looks like it's pointing to the old OAUTH endpoint that was on prem or ST.  It most likely will not work in MT, and OAUTH is deprecated in MT anyways requiring OAUTH2 to be used in IONAPI.  I know there was recently an update to the H5 SDK project, but I haven't looked at it, have you tried with the new release?

Reply
  • Greetings;

    A 404 error is not a not found reply.  Can you access that URL in a browser?  Is this ST or MT?  That code looks like it's pointing to the old OAUTH endpoint that was on prem or ST.  It most likely will not work in MT, and OAUTH is deprecated in MT anyways requiring OAUTH2 to be used in IONAPI.  I know there was recently an update to the H5 SDK project, but I haven't looked at it, have you tried with the new release?

Children
No Data