The Infor Communities is globally accessed system by Infor and its customers, please do not post or upload any content that could be deemed as sensitive, confidential or subject to any data regulation requirements. If you are unsure whether or not the content contains sensitive, confidential or has any data regulation requirements, please seek the advice of your internal security, legal, and compliance experts.

Infor OS 2020-06 Install Errors

Got all the way towards the end of the install and got the following errors when the installer went to create the IIS virtual directories:


Any idea of what is causing this? I did turn off notcount on the SQL Server and enabled the "8DOT3" naming on the servers (followed by restarts) as various KBs indicated. But not finding any answers for these error messages. Using Windows Domain administrator account for all account specifications. 

Infor OS Server:

Windows 2019 Server

34GB RAM (bumped it up in VMWare to get 32GB free)

4 Cores x 2.5 GHz

300GB free disk space

SQL Server:

Windows Server 2019

SQL Server 2016 SP2


2 Cores x 2.5 GHz

250GB free disk space

  • Bumping... Anyone have a clue about these error messages? Anyone, anyone, Bueller?!

  • Hi, Tim.  Is this a clean, fresh install or an update to an existing deployment?  I plan to try updating our 12.0.40 to 2020-06 soon, then will coordinate updates with customer deployments.

    Did you by chance check Event Viewer to see if any additional clues might be provided there?

    Not sure that it'll be related, but I have encountered the 'gotcha' where the NT Service account isn't in place (NT SERVICE\ALL SERVICES must be added to Local Policy > Log on as a service.).  That can throw some errors for you.  Another basic check is to ensure you have communication to all servers involved in the deployment.

    Hope this at least provides a sanity check for you...

  • Thanks for the response! Clean install. Didn't see anything in Event Viewer related to those error messages. Had to use specific accounts (used domain administrator to ensure no issues with permissions or log in as a service) because the installer bombed when it tried creating the service accounts. Quadruple checked that all servers could communicate with each other and turned off Windows Firewall to make sure there are no port issues.

    This has been a pretty consistent issue for me since I started trying to create a test environment to explore Infor OS since the 11.x.x versions. Have never gotten past the IIS virtual directory creation part of the installer. It always dies there for me.

    Some things I have learned and added to my build attempts:

    • 32GB of memory is a must
      • Built a new server with 128GB of memory and assigned 34GB to this recent server build attempt
    • Enable 8DOT3 naming
      • This was mentioned on previous threads as solving various issues around folder and virtual directory creation
    • Disable nocount in SQL Server properties
      • I have adopted this in my installs based on other people's feedback but don't know if this ever made a difference for me or what it does for the installer
    • Use specific domain name SSL certificates instead of wildcard certificates
      • For some reason the installer doesn't like standard wildcard certificates and I had to switch to creating separate certificates tied directly to the hostname of the server. Not sure why this is a requirement because production systems would normally be load balanced and the node servers would have different hostnames than the alias used on the certificate, e.g. external alias =, nodes =, The installer should not care what the node names are as compared to the hostname in the certificate, but for some reason it does.
    • Separate DC, ADFS, SQL, and Infor OS servers
      • Early on I tried to install ADFS on the DC, but the installer didn't like that. So ever since my DC, ADFS, SQL, and Infor OS servers have all been separate VMs.

    Does anyone have any other tips/procedures they have done that helped them get Infor OS to install?