Blank Document id for CustomBod

I have tried creating a custom bod in our Cloudsuite Food & Beverage. I have manage to get it working through the whole flow but in OneView, the document id is blank.

I have configuered the identifier path in the object schema but still it is not picked up.

This is how it looks like in OneView:

I have attached an export of the Schema as well.

CustomCustomer.zip

Am I missing something in the setup?

Parents
  • Hello,

    This is working here :

     

    How did you defined your file connection point ? Are you using a file template or a full document ?

  • Hi,

    The file definintion in the connection point was the full document, but I also tried to change it to File format but with the same result.

    However, if I create an xml file according to the file template format (only containing the information in the CustomerData tag), then I also get it to work. But in my scenario I want M3 to create a custom BOD through IEC and in this case the full BOD format is required in order to pass it into ION since it is using the IObox. In this case I do not get it to work.

    This is and example file that was created by M3:

    CustomCustomerExample.xml
    <?xml version="1.0" encoding="UTF-8" ?>
    <SyncCustomCustomer xmlns="http://schema.infor.com/InforOAGIS/2" releaseID="9.2" versionID="2.12.1" systemEnvironmentCode="Production">
    	<ApplicationArea>
    		<Sender>
    			<LogicalID schemeVersionID="3">lid://infor.m3.m3</LogicalID>
    			<ComponentID schemeVersionID="16.0.0.20190922120042">M3BE</ComponentID>
    			<ConfirmationCode>OnError</ConfirmationCode>
    		</Sender>
    		<CreationDateTime>2019-11-07T10:58:18.696Z</CreationDateTime>
    		<BODID>1d45f374-b690-4a99-8915-ddbf6cfc3e97</BODID>
    	</ApplicationArea>
    	<DataArea>
    		<Sync>
    			<ActionCriteria>Replace</ActionCriteria>
    		</Sync>
    		<CustomCustomer>
    			<CustomerData>
    				<CustomerNumber>11009-1</CustomerNumber>
    				<CustomerName>Customer A-8 AD</CustomerName>
    				<Status>20</Status>
    			</CustomerData>
    		</CustomCustomer>
    	</DataArea>
    </SyncCustomCustomer>

  • I suspect the default namespace.

    Can you check your agreement in MEC and activate parameter "Do not write namespaces of output file" on the "XML transform" step?

     

    Save, reload cache, retry.

  • We are running MT Cloud so Parter Admin is no longer in use. I tried to remove the namespace in the following parameter but it didn't help:

Reply Children